Category: Raspberry Pi

[TUTORIAL] Setup GCC6 on Raspberry Pi

As of the latest version, MAME now requires GCC 5 as a minimum to compile. Raspbian Jessie ships with GCC 4.9.2 which, at nearly 2 years old, is now just a little too stable. GCC 6.2...

Compiling MAME on Raspberry Pi

Compiling MAME on a Raspberry Pi is pretty easy. It’s been a supported compile target for a few revisions now. The minimum you need to do to get a working compile is this…
apt-get install git build-essentials libsdl2-dev libsdl2-ttf-dev libfontconfig-dev qt5-default and make
This will give you a build of MAME that works but I don’t think anyone would call it usable on a board as slow as a Raspberry Pi. So what can we do to speed things up a bit?